High Voltage Coils

electrical and mechanical engineering

Home - Motorcycles - Ural Ranger Model 2014 fuel sensor and indication lamp

Ural Ranger Model 2014 fuel sensor and indication lamp

Posted on 17. July 2016 in Motorcycles

Hi folks,
my favorite motorcycle has a little issue. A fuel sensor is available in the newer models. It is directly connected to the fuel indication lamp. If no fuel is present, the lamp is lit. Problem is, after turning the ignition, it does not flash up, so you dont have an indication if the fuelsensor or lamp is working. If you drive longer routes and you rely on this feature, you may find yourself in a situation without gas.

I developed an easy solution with just a few parts.

stecker

The original connectors used are from the company MOLEX
Mizu-P25™ 2.50mm Pitch Waterproof Wire-to-Wire Plug Housing, 3 Circuits

MALE
52116-0341
MALE_CRIMP
50038

FEMALE
052117-0341
FEMALE_CRIMP
50039

All products are available from the electronic supplier tme.eu (which kindly also ships to private households)
male crimp
male connector

female crimp
female connector

Next step is to get a working hardware, for this application i wanted to have some features:
* Using original waterproof connectors and housing, no soldering should be done for easy swapping and replacing any parts
* Sensor voltage protection, no more then 12V to the sensor
* Sensor output driver does not drive any load (13kOhms)
* Lamp short circuit protection, current is limited to 100mA
* After Ignition do a lamp test for ~500ms, then 500ms shutdown, then use the sensor value

schaltplan

The controller used is a Atmel ATiny13V, which works at 2MHz @5V. The code is written in plain c.

int main(void)
{
	// PB0 = GND
	// PB1 = sensor reading
	// PB4 = lamp output
	DDRB=0x10;
	PORTB=0x00;
	_delay_ms(500);
	PORTB=0x10;
	_delay_ms(1000);
	PORTB=0x00;
	_delay_ms(500);	
	PORTB=0x00;
	while (1)
	{
		if (PINB & 0x02)
		{
			PORTB = 0x10;
		}else{
			PORTB = 0x00;
		}		
	}
}

there is a testvideo available on youtube, folowwing this link

A possible improvement would be to debounce the digital inputs and adding a low pass filter, which will remove unwanted blinks if the sensor is only half wet.

4 thoughts on “Ural Ranger Model 2014 fuel sensor and indication lamp”

  • Trevor Lewis says:

    Do you have problems with EFI Urals in Europe having the electro-optical sensor fail? Sensor failure is rampant here in the USA- if you do not have it in EU then perhaps it is caused by our stupid-government-mandated 10% ethanol in our fuel damaging our sensors. It would be helpful and informative to know if the problem is confined to the US and our fuel. Thank you

    • Michael says:

      Dear Trevor,
      i know of two machines with the same sensor problems,
      just died after several months of driving.

      In my opinion the sensor is very sensitive
      to overvoltage (spikes from the alternator,
      managable battery loader etc) and too much
      output load (caused by the electronic high side
      switch, which is not designed to drive
      a 0.5W to 1W light bulb).

      The contents of the fuel should not have an impact
      on the sensor, because it is highly encapsuled and
      works on an optical base.

      My upgraded Sensor is now installed approx 1 year,
      summer and winter driving about 3000km, with my modification
      no problems so far.

  • Trevor Lewis says:

    Thank you Michael. Here when the failed sensors are removed, the non-threaded forward part has swelled up to such a degree that threads are formed in it upon removal. This seems to suggest that something in the fuel is affecting the material to an extent including physical distortion, which could throw off the reflective/ refractive function of the device. In the US there has been an upgraded set up with an LED replacing the indicator light. I also agree with your sense of voltage spike vulnerability so I am also looking into similar sensors that can handle greater swings in supply voltage, and more current on the switched line. Thanks

  • Philippe says:

    Hello from Arizona. After not less than 4 warranty replacement (12000kms)I am growing tired of my low gas level light… does this system works with the newly installed LED?
    Any chance you will sell your system ob line?
    Thank you

Leave a Reply

Your email address will not be published. Required fields are marked *